解決Windows10 使用WSL2 導致VMware「出現與Device Guard 不相容導致無法運行與創建虛擬機」問題

前陣子開始使用WSL2的工具套用在新的伺服器覺得非常穩定。
所以這幾天就在開發用的電腦安裝WSL2,結果一直無法順利使用,當可以使用後換成 VMware 出現Device Guard 不相容錯誤!!

後來經過研究才發現Hyper-V 會導致WSL2 和VMware 會衝突無法共用,VMware的部落格也有告知後續更新會解決此問題!

參考來源: https://blogs.vmware.com/workstation/2020/05/vmware-workstation-now-supports-hyper-v-mode.html

首先將Windows10和VMware 更新到以下版本之上
Windows10 2004 / build 19041.264
VMware Workstation 15.5.5

Windows載點 / Linux載點

接下來開啟 VMware,點選settings

將紅框處有勾選的全部取消,並確認。

然將電腦重新啟動, WSL和VMware皆可正常使用。

關於作者 Roy

軟體工程師,主要專注在後端開發


發佈留言